XWindows, Xterm and TWM on WebOS

So here’s this weeks experiment… Tho it’s not working out as well as I hoped.  I can get TWM to run which helps quite a bit….but can’t get RDP to properly accept keyboard mappings.  

I’ll post some details later, but here’s a screenshot.

3 Comments.

  1. In case your wondering, the binaries for TWM, Xvkbd, and XfreeRDP were grafted out of Debian ARMEL packages. Ran LDD against each and most libraries I was able to get from Optware (use Preware to install). Any others were grafted out of yet more Debian ARMEL packages. All tossed into /opt/lib then manually run ldconfig /opt/lib (which appears to need to be run every reboot??).

  2. So in case anyone was wondering… I’ve made some progress and will post details shortly. Basically I switched to ‘rdesktop’ instead of ‘freeRDP’ to deal with some library & keymap issues.

    xvkbd sucks tho… crashes and has a pile of problems. But is really the only way around sending ctrl or esc in here at the moment. (well, other then using an external keyboard)

    oh that brings me to another point.. if you’re using the Apple wireless keyboard, esc still doesn’t work properly all the time. But Ctrl-C will get you into command mode in VI. 🙂

  3. So I’ve been going crazy with the whole ‘get a secondary keyboard going in X’ to deal with the whole lack of Ctrl or Escape keys on the flipping Touchpad popup keyboard. Now looks like my problems are solved. JBlather at PreCentral has found you can indeed send Ctrl & Esc from the keyboard! You ?simply? hold down the ‘t’ key and hit the right most option that appears. That simulates ctrl. Then hit any other character for Ctrl-Blah. For escape,you do Ctrl-[

    here are the details:
    http://forums.precentral.net/3154664-post1.html

    –Chris